Savvy Content Manager Community

Community for users of Savvy Content Manager

I am getting an error after the upgrade and the site will not load.

I updated all the files that normally would do except for config/includes.cfm and config/savvylicense.cfm, added the new files that didn't exist in the current installation.

I ran the /install/ directory to update the db and create the new config file with the editor option in it and everything went well.

When I reinited savvy, I restarted coldfusion, and I still get an error.  The error logs say: "was missing server information."

I started tracking it down and in the displaycontentobject.cfm file I get an error at line 11 -     <cfif session.savvy.iscontributor eq '1'>

If I cfdump session.savvy there is data in the array.

Any ideas?  We need to upgrade all 7 of our sites and until this is figured out we can't do much editing because of the firefox 10 issue.



Views: 157

Reply to This

Replies to This Discussion

 is an application.cfm file in either the root or the actionfile folder if so remove.  Only Application.cfc should exist and only in the root.  

Also can you link to the site so we can see the error?

Application.cfc is at the root, same as always.  I had to roll back to the old version so the site stays up for visitors so I don't have a URL to send you to view the error.

Was there any more to the error?  Did you get an email with it?  Any additional detail for the error at all?

When I turned on debugging I found the file that whole thing was choking on.  The file was corrupt from the zip file.  I unzipped it again and this time the file was not corrupt.  Uploaded it and everything seems to be fine.

I spoke to soon.  Went to login and this is what I got:  edited path


11:15:48.048 - Expression Exception - in = {..........}/actionfiles/cfc/security.cfc : line 474
       Element OBJECTDATA.TEMPPASSWORD is undefined in ARGUMENTS.      

Check to make sure that your login and logout files were also copied over, in addition to the /actionfiles/cfc folder.

And disregard the last one, needed to replace the login from when I rolled back from 4.7.8 so the site could work.  Seems the original and only problem was the corrupt file.



New feature requests for Savvy 2 Replies

Started by Sherry Labonte in Extending Savvy. Last reply by Bill Savoie Feb 25, 2015.

Recently upgraded and with CKEditor the styles dropdown is not populated. 2 Replies

Started by William Mallett in Using Savvy. Last reply by William Mallett Aug 26, 2014.

Savvy 6 Install on CF11 1 Reply

Started by Renee Wasula in Installing Savvy. Last reply by Sherry Labonte Aug 26, 2014.



© 2019   Created by Bill Savoie.   Powered by

Badges  |  Report an Issue  |  Terms of Service